Performance degradation

Incident Report for Matrix Booking

Resolved

The system is operating as expected following updates today. We will continue to monitor this tomorrow but we are closing this incident now, apologies for any inconvenience caused.
Posted Dec 15, 2025 - 15:00 UTC

Update

A second fix has now been applied and we are continuing to monitor the performance of the platform.
Posted Dec 15, 2025 - 14:29 UTC

Monitoring

We have identified 2 issues regarding the way in which images are handled within the new web application interface.

A fix to this has been deployed and we are currently monitoring the performance.
Posted Dec 15, 2025 - 11:46 UTC

Identified

WE have identified an issue and we are currently progressing a fix for this now.
Posted Dec 15, 2025 - 09:59 UTC

Investigating

We are currently investigating a degradation of performance on the Matrix Booking web application.
Posted Dec 15, 2025 - 09:47 UTC
This incident affected: Web applications.